Updated to 7.4 RC1 and now ads aren't being filtered, even with filtering on

halcyonboy

New Member
UPDATE:
Ok, so it appears that it is an issue when you update to the latest RC1 version. Before downgrading to the release version again, I thought I would try one more thing to see if I could resolve this and rebooted my machine. Post reboot, it appears that things are working again. The update didn't ask me to reboot either, but glad to see it isn't as big an issue as it first appeared.

ORIGINAL POST:
After updating I noticed that on one of my regular local tech news sites, all the ads are now showing. I had to install the adguard blocker extension (not referring to the new assistant) to get the ads to be blocked as expected (I noted that it no longer shows as working in integrated mode).

I also tried manually using the "block ads on this website" feature in the new adguard assistant extension to manually go and select the ads to block. I did this and it appeared to be working, but browsing to another article on the same site, shows all the ads have returned, as have the ads on the homepage which I had also specified manually this way.

I have also checked on several other sites and ads are being displayed and not blocked. I have checked for filter updates and the problem is still occurring.

I have checked in Edge Chromium-based (versions 84.0.488.1 [dev], 83.0.478.13 [beta] and 81.0.416.64 [release]), Firefox (v 75.0), and Opera (v 67.0.3575.137 and v 68.0.3618.56). I have the adguard assistant installed on each of these, and have verified that it is connected to adguard for windows. Adblocking was not working in any of the browsers mentioned.

Additionally I tested other sites: https://mspoweruser.com, https://www.news24.com, https://www.windowscentral.com, https://www.androidcentral.com, https://www.zdnet.com, and https://www.onmsft.com. And all were still showing ads when they should not have been.

Ad blocking was working perfectly with Adguard 7.4 Beta 2, so not sure why its now stopped?

I have also submitted a page showing the issue via the report this website feature, here is the github link: https://github.com/AdguardTeam/AdguardFilters/issues/54487
 
Last edited:

halcyonboy

New Member
Hi @aegis,

I'm on the most current version of Windows 10 Version 1909 (build 18363.815), and it didn't say anything about rebooting. I ran the update on one of my other devices, and it also didn't ask me to reboot.

Once I clicked "update" it downloaded and then adguard disappeared, there was no ui visible at all, and then it started up again running the updated version. No messages or feedback at all. Was the same on both machines I tested it on.
 

kavabanga

Windows developer
Staff member
Administrator
@halcyonboy, сould you please reboot your computer. Is filtering on the other webpages is ok (e.g. google.com etc.)? Could you please check the list of https exclusions - there can be that sites are in this list
 

myMoon

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@halcyonboy

Hello, regarding the issue :

Somehow the certificate seems to be lost after the update, and after rebooting the PC, AdGuard re-installed the certificate thereby eliminated the advertising problem.

But to be sure can you gather the log files by the article and send it to devteam@adguard.com with the reference subject to this thread?
 
Top