WebRTC leak suppression

ycxv

New Member
Hello, I'm using AdGuard with NordVPN seted up via Proxy settings. Everything works fine except my IP can be seen. Is there any solution to fix that? Maybe some rule that I can manually add to user filter. I've tried to switch some flags related to webrtc via chrome:flags but with no success.
 

ycxv

New Member
I've found a solution on your forum: https://forum.adguard.com/index.php?threads/prevent-webrtc-from-leaking-ip-address.19273/#post-141134
Code:
#%#window.webkitRTCPeerConnection = undefined; window.mozRTCPeerConnection = undefined; navigator.mozGetUserMedia = undefined; navigator.webkitGetUserMedia = undefined; window.MediaStreamTrack = undefined; window.AudioContext = undefined; window.webkitAudioContext = undefined; window.RTCPeerConnection = function() {};
But I do not know is this good for doing it that way. I think it may also block something useful.
 

Boo Berry

Moderator + Beta Tester
Moderator
Well, that rule blocks all WebRTC connections. If that's what you want to do (e.g. you don't have any use for WebRTC) it *should* be okay to use. I've been using that rule for some time now and it's worked out fine here.
 
How about having an option in the adguard menu to disable WebRTC Connections as a Yes/No ?

That should satisfy most people's requirements for this and make it easy for people to enable/disable it.
 

Boo Berry

Moderator + Beta Tester
Moderator
It'll happen once Stealth Mode lands in AG for Android (as part of CoreLibs). But the devs are waiting to land CoreLibs in every AG app (AG for Android, Mac and Windows) before adding features like Stealth Mode. So for the meantime, the above rule works fine.
 
Top