WFP driver caused issue of being unable to access router settings + loading of certain websites

Hitokage

New Member
Steps to reproduce:

1. Uncheck and disable every settings on the main page (optional)
2. Turn on WFP driver (OS restart may be required)
3. Go to 192.168.1.1 on a browser
4. Try clicking sign in
5. Browser will get into infinite loading, regardless the entered credential is correct or wrong.

Tested devices / softwares:
-Windows 10 Education 1803
-ASUS Router RT-AC88U (Firmware 3.0.0.4.384_32799)
-Adguard 6.3.1399.4073
-Mozilla Firefox 62.0.3
-Google Chrome 69.0.3497.100

Workaround:
-Turn off WFP driver
-Uncheck the browser (used to access 192.168.1.1) from the Filtered Apps list
-Exit Adguard completely

I don't know exactly when this first happened as I don't usually access my router settings, but it's not like this in the past and my WFP driver has always been on. However, if this issue is linked to some websites being unable to load successfully, then I would estimate it as around 2 weeks ago.

One of the websites in concern:
treeofsavior.com/page/main

Most of the time (like 80-90%) it will not load completely successfully, and in the case of Firefox, letting it to attempt loading for like another 10 seconds will result in the following error:

Secure Connection Failed

An error occurred during a connection to treeofsavior.com.
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.
Same issue - WFP driver. Upon disabling it, I have no issue with the website.
 

Hitokage

New Member
Alright I think my Emsisoft Anti-Malware has something to do with this. I'm using 2018.9.1.8968 version of it.
Closing it will solve the issue with accessing router settings when WFP driver is on. But of course I am choosing to have Emsisoft on while WFP driver off instead.

As for the issue with some websites being unable to load properly when WFP driver is on, I'm somehow not encountering such issue anymore for now even with both WFP driver and Emsisoft on.
So the only issue left is accessing router settings with both WFP and Emsisoft on.
 

Boo Berry

Moderator + Beta Tester
Moderator
Yeah, sounds like it's an incompatibility with AG's WFP driver and Emsisoft. It's not surprising as WFP incompatibilities pop up from time-to-time.
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Hitokage

Please, add this rules to the user filter and try again:

@@||192.168.1.1^$document
@@||treeofsavior.com^$document
 

Hitokage

New Member
@TheHasagi

Tried and it doesn't work. I doubt editing the filters will do anything because even disabling the entire ad blocker module still result in the same thing.
I have no issue with other websites anymore, just the router settings. I don't mind temporarily disable WFP driver to access the router settings since I don't do it often, so this issue isn't a big deal to me anymore.

But I guess it's good for you guys to know that there's an issue with WFP + Emsisoft, and I can help out with any further testings you would like me to try regarding this issue.
 

Hitokage

New Member
Very weird, but the website issue is back again. Same thing, disabling either WFP driver or Emsisoft will solve the issue.
For now I guess I really have to disable WFP driver.
 

Cister

New Member
Hello,
I run on my Windows 10-1809 Adgard for Windows with WFB driver and also Emsisoft without any issue since many years.
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Hitokage

Hello!

Can we cooperate in private messages so I'll try to solve this issue via TV (TeamViewer) session?
 
Top