What causes Adguard to block my internet connection?

NeedHelp

New Member
I thought it might be a problem with my phone or a software conflict causing the connection issue. However, Disconnect works flawlessly, plus provides a secure connection for public wifi. Although I prefer Adguard's flexibility to configure individual apps internet access when it works. The widespread and long time issue of constantly loosing all network connectivity rendered the application useless for me for mobile devices.
 

NeedHelp

New Member
Try Disconnect, which blocks ads and offers secure internet communications. Adguars app has a long history with this issue.
 

myMoon

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@NeedHelp

Hello!

Try to check if these two parameters are set to true in AdGuard - Settings - Advanced - low-level settings - pref.vpn.disable.reconfigure/pause.
 

Rupee

New Member
I am still having this issue with Oppo A3s running android 8.1 with latest version of adguard installed. It is really annoying because I have to disabled and enable adguard every time I move from 1 cell tower to another cell tower.

Also this does not happen on Chrome or Speetest app.

It happens on Twitter app all the time when wifi or cell tower changes. Twitter will not load new tweets because network changed :mad:
 
Last edited:

Momowho

New Member
I've updated Adguard to the latest version and this issue much more pronounced now on my Note 8.

It used to be once in 3-5 days.

Now it's every few minutes.

What can I do to help solve this annoying issue faster?
 

Luigi

New Member
Yes, I'm also having the same issue: internet will totally stop.

I can go anywhere between 2 minutes & 10 hours between adguard dropouts (& internet resumes every time I stop & restart Adguard...

problem is only with my android devices (eg: sony xperia XZ1 Compact android 9 stock rom, M8S pro S912 android TV box with stock android, Samsung galaxy tab A 10.5, etc)... but NO problem with the windows software...

if I turn off AG android dns filtering, then I get no dropouts, BUT: some apps with "on screen ads", will suddenly start switching to the browser, & show me a "blocked ad" page... also very annoying, as I have to keep switching back to the app, only to have the browser pop-up a few seconds/minutes later.

Its obviously an issue with adguard, on android, when dns filtering is enabled in settings... I'll put up with it for now, since I purchased the lifetime license... hoping that this gets fixed sometime in 2019, or 2020, or 2021...
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@Luigi

Hello!

Please tell me you tried to change DNS providers (AdGuard settings > DNS Filtering > Select DNS server)? Try to choose different providers and change Server type (DNSCrypt/DNS-over-HTTPS/TLS)
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@Rupee


Of course, we have a 60-day money back guarantee. Therefore, if you do not like AdGuard after purchase, you can get a refund.
To get a refund for a license key(s) purchased on official website https://adguard.com you need to contact the support team: support@adguard.com
Processing time will depend on payment method you have chosen and usually takes up to 5-10 business days.
 

Luigi

New Member
The suggestion from @Chinaski seems to work. I experimented with it after my post...

It looks like it doesn't matter which DNS server you pick, as long as its NOT the "System default"...

So this now raises another question: most unsophisticated users would never think to change these settings... so why allowing the default setting to hobble the device its running on?

I'm stubborn & have been struggling with this for over 12 months before I stumbled across the answer... most other users would have just uninstalled adguard, & avoided using it in the future... probably also telling friends to also avoid it

I appreciate all the hard work thats gone into adguard, which is why I purchased it... but why would the maker(s) of adguard shoot themselves in the foot like this?

Although it doesn't affect me anymore, adguard android still has my original issue: DNS filtering is off by default, but that means you get many apps with undesirable browser "pop-ups" with blank "blocked" pages... so a constant switching between an app & the browser... again, enough to scare away many users
 

Luigi

New Member
I set the dns filtering setting to use the Cloudflare server. I'm in Australia, where internet speeds are like those of a 3rd world country... so I need something FAST
 

Luigi

New Member
yeah, well, I use NordVPN together with adguard... again, for speed... Australia is a big country & a long way from the rest of the world :-(
 

Rupee

New Member
Switched to a Samsung Galaxy 10e and all my problems with Adguard disappeared ;) Must have been an issue with my previous Oppo A3s compatibility with it.
 

BACILIYATSIA

New Member
I am still having this issue with Oppo A3s running android 8.1 with latest version of adguard installed. It is really annoying because I have to disabled and enable adguard every time I move from 1 cell tower to another cell tower.

Also this does not happen on Chrome or Speetest app.

It happens on Twitter app all the time when wifi or cell tower changes. Twitter will not load new tweets because network changed :mad:
However, Disconnect works flawlessly, plus provides a Xender Discord Omegle secure connection for public wifi. Although I prefer Adguard's flexibility to configure individual apps internet access when it works. The widespread and long time issue of constantly loosing all network connectivity rendered the application useless for me for mobile devices.
 
Last edited:
AdGuard has started blocking my internet connection out of nowhere on my rooted Android tablet. It was working fine for about 2 weeks and today decided to start blocking all internet connectivity.

Tried switching the DNS server and the nightly build but neither of those helped.

Finally, I set the DNS server type from DNS-over-HTTPS to DNS-over-TLS under the Cloudflare server which seems to have helped.

Strangely, it's working just fine on its default configuration on another Android device (a phone).

Can we have a fix for this any time soon? The workaround doesn't give me a lot of confidence and also seems to lower the internet speed.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@Prakhar Srivastava
Hello!

Try to check if these two parameters are set to true in AdGuard - Settings - Advanced - low-level settings - pref.vpn.disable.reconfigure/pause.
 
Top