What causes Adguard to block my internet connection?

freshhh

Active Member
I have noticed the same issue with all latest versions Stable or Nightly.
This behavior has appeared for several months already.
DNS Adguard / DNS google: same thing
if AdGuard off 4G is working fine
no trouble with wi-fi
 

freshhh

Active Member
it's not exactly the same bug - it's not that i'm losing connectivity - i don't have any 4G connectivity at all !
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
Then let’s do the following:
- AdGuard > Settings > Advanced > Logging Level > Record All.
- Reproduce your issue.
- Note the time the error occurred and let us know.
- Don’t forget to return to the default logging level.
- Logs can be sent to me at PM or on devteam@adguard.com
 

freshhh

Active Member
Then let’s do the following:
- AdGuard > Settings > Advanced > Logging Level > Record All.
- Reproduce your issue.
- Note the time the error occurred and let us know.
- Don’t forget to return to the default logging level.
- Logs can be sent to me at PM or on devteam@adguard.com
I did that but the weird thing is that there is nothing special to see...
Nothing unusual...
 

jineshpatel30

Beta Tester
Then let’s do the following:
- AdGuard > Settings > Advanced > Logging Level > Record All.
- Reproduce your issue.
- Note the time the error occurred and let us know.
- Don’t forget to return to the default logging level.
- Logs can be sent to me at PM or on devteam@adguard.com
I did that but the weird thing is that there is nothing special to see...
Nothing unusual...
I'm having same issue and I already reported to GitHub 2842 but as I mentioned there, It's not at all related to connectivity change as my phone stays on WiFi for days without changing to mobile data (if fact mobile data is off and I turn it on manually when there's power cut of something)

So, Issue is much bigger than simply related to switching.


But I think I found a work around. before coming to it let's talk about how I found it, so that you can have sense about what probable issue/solution may be
(It's going to be a long story since it took me more than 12 hours and Various iteration of Adguard fresh install and even previous versions till 3.2!)

My Setup
Android 10
3.4 Stable
All Adguard recommended filters on, NO user filter or other weird filters.
NO DNS/Malware Protection/Stealth of anything else just plain Ad blocking through above filters
System Security Certificate for HTTPS (pushed with root)


Yesterday I download Angry Birds 2 (AB2), which obviously has lot of ads so I let Adguard do it's work BUT surprisingly it gave no internet access on first open itself. So i checked Adguard Assistant Logs and indeed there's no requests from AB2 there then I restarted Adguard manually and opened AB2, this time also same No internet Notice in AB2 but Adguard Assistant Logs had entries this time so by trial and error I came to rule
Code:
@@||config.uca.cloud.unity3d.com^$app=com.rovio.baba
Now it should work right? BUT no it didn't. (Well It'll work if AB2 had first run without Adguard blocking internet as subsequent runs don't need internet to play but if you click AB2 setting Icon and click of cloud to save progress on cloud it'll say "connection fail" even though we exempted above code (It's the one one required even though Adguard blocks others unity request it;s fine you'll see latter)

So next step obviously is to turn off HTTPS filter for AB2 but still the same issue (Though Adguard didn't suggested me to put it on ignore list with VPN blocking method So I re-enabled HTTPS as it wasn't solving any problem We'l come back to this latter)

Keep in mind that once Adguard start blocking internet it spread to all other apps as well not just limited to AB2 blocking.

So finally out of blue, I thought about trying proxy blocking method first time since I started using Adguard.
Since I have root it wasn't much trouble for me to switch to Proxy blocking.

As soon as I switch to Proxy and opened AB2 Adguard notification came that I need to exclude HTTPS for AB2 as it doesn't trust certificate. Now recall same didn't came with VPN method (I disabled it for checking on my own)

So I excluded HTTPS for AB2 and exception rule was already there from before
Code:
@@||config.uca.cloud.unity3d.com^$app=com.rovio.baba
And Voila !


Cloud Saving Start connecting in AB2 and since then I also don't have any any network drop in other apps like before when Adguard was randomly blocking Internet access.

So In conclusion, AB2 was just a means for me to get to this workaround as Real Issue is VPN blocking method!

Bonus: One of my iteration was to try logging network request from AB2 without installing Adguard at all. I used httpcanary App and to my surprise even without any Ad-blocking/Adguard Installed, config.uca.cloud.unity3d.com was still failing to connect just because that app also use VPN !

That gives me a theory that there's some issue with VPN in Android 10 (May be 9 as well) which makes few connection fail even without any ad-blocking. Tough unlike Adguard httpcanary wasn't blocking Internet Access to other apps randomly. So, My final thoughts, there may be issue at VPN level as well as Adguard level.

I Hope this was helpful and you guys have better luck tracking down the actual issue.
 
Last edited:

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
@quyleanh

Hello there!
I pass the provided info to the developers.
If there are any references, I'll let you know.
 

KaKi87

New Member
I'll be trying this as of now, thanks for the suggestion.
However, will that decrease ad-blocking efficiency ?
 

Chinaski

Quality Assurance
Staff member
Administrator
Moderator
No, it's not going to affect the quality of the ad blocking.
 

KaKi87

New Member
So, at first, I thought I would only have to disable "DNS requests blocking" but it didn't solved the issue, so I disabled the entire "DNS Filtering" module and the issue seem to be gone.

However, I absolutely need "DNS filtering" to be enabled, because I need to use uncensored DNS servers.

Thanks
 
D

Deleted member 37151

Guest
I thought it might be a problem with my phone or a software conflict causing the connection issue. However, Disconnect works flawlessly, plus provides a secure connection for public wifi. Although I prefer Adguard's flexibility to configure individual apps internet access when it works. The widespread and long time issue of constantly loosing all network connectivity rendered the application useless for me for mobile devices.
Hi there,
Enabling DoH or DoT for any DNS server from within the Adguard app breaks my internet connection. I’ve tested this on multiple networks, same issue. Check It first.
But Adguard is the best option ?, Only thing holding me back from subscribing to ADGuard Pro for Mac are the system resources.
Pretty much up to you. IMHO it’s worth the resources it consumes, which is negligible for even my first gen aluminum MacBook. Omegle System wide filtering without having to manage independent configurations in different browser extensions is nice. What resource intense processes are you running that would cause you to pause on adding AdGuard?
 
D

Deleted member 37151

Guest
Hi there,
Enabling DoH or DoT for any DNS server from within the Adguard app breaks my internet connection. I’ve tested this on multiple networks, same issue. Check it first.But Adguard is the best option?,Only thing holding me back from subscribing to ADGuard Pro for Mac are the system resources.
I try and keep my system as efficient as possible so I pretty much zero apps running at startup or in the background. Still gauging if the Omegle system wide AdBlocking and tracker blocking is worth the system resources. Safari is typically where I see ads anyways and AdGuard for Safari is working just fine.
Any opinions on this?
 

KaKi87

New Member
Hello,
I noticed two more things since the last time :
1. disabling DNS filtering did not removed the issue after all
2. disabling then re-enabling wifi is a working and faster workaround than restarting AdGuard.
Thanks
 

KaKi87

New Member
3. AdGuard is a Schrodinger app : while running in background with working Internet, bringing it in foreground automatically triggers the bug.
 
Top