Whitelist not working for some sites

planetary

New Member
Hi Adguard developers,

I noticed that Adguard triggers anti ad block warnings on some sites (e.g. http://www.spiegel.de), even if the site is in Adguard's whitelist (the site is listed in the whitelist, and the switch button in the Adguard popup is red for this site). Reloading the page with Safari's built-in "Reload Without Content Blockers" option makes the warning disappear.

I would have thought that whitelisting and reloading without content blockers would do the same stuff under the hood (loading the page without Adguard), but that does not seem to be the case.

Is there anything I can do to really disable Adguard for sites like spiegel.de?

Thanks!
 

MacNick

New Member
I second that, same problem on sueddeutsche.de
I tried adding the page to the whitelist and also tried adding a custom filter like this
Code:
@@||sueddeutsche.de
but to no avail. Any suggestions?
 

Blaz

Moderator & Translator
Staff member
Moderator
With mentioned rule you only disable URL blocks rule for this specific domain (third-party block rules will still function). Add this rule to your user filter to disable filtering:

Code:
@@||sueddeutsche.de^$document
 

MacNick

New Member
Thank you! Tried that, but unfortunately, it didn't work. I added your filter (instead of my old one), even unchecked the filter checkboxes (as seen in the screenshot) but still the website runs into an adblock-script ...

 

Blaz

Moderator & Translator
Staff member
Moderator
Please try this rule:
Code:
@@||sueddeutsche.de^$document,important
I noticed we already have a generichide exclusion in our German filter and therefore previous rule did not work.
 

MacNick

New Member
Tried this rule, too, but no change in behavior. However, I noticed you can register a free account on sueddeutsche.de that will allow visiting it with an adblocker enabled. Therefore, my problem is solved in a way that works for me …
 
Top