[WIN] [Solved] AdGuard is blocking RBS Log In page.

Pentlands

Beta Tester
Hi,

When Adguard protection is enabled i cannot open my bank's Log In page, Adguard is blocking it.
http://personal.rbs.co.uk/personal.html
Note: The "Log In" button is located on the right of the banner at the top of the page.

The only way i can get access to the page is to "disable protection".

I get the same result in both IE11 & Firefox 34.0.5

Adguard version 5.10.1188.6174
I looked to see if there were any updates, but apart from one English Filter update, which didn't make any difference to this issue there were none.

Of concern also is that Adguard didn't alert me it had blocked the page, perhaps my fault as i may have disabled a setting within Adguard by mistake?

FYI, the following page is displayed by IE:

This page can’t be displayed

•Make sure the web address http://www.rbs.co.uk is correct.
•Look for the page with your search engine.
•Refresh the page in a few minutes.

And with Firefox:

The connection was interrupted

The connection to www.rbsdigital.com was interrupted while the page was loading.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Regards
 

Blaz

Moderator & Translator
Staff member
Moderator
Reproduced here, TLS 1.2 must be enabled according to the site.
 

Pentlands

Beta Tester
Reproduced here, TLS 1.2 must be enabled according to the site.
Thanks for reproducing it :)

I only have a vague understanding of what TLS is and how it works, but i can say i didn't see this happen on this website until after updating to 5.10.1188.6174

Regards
 

avatar

Administrator
Staff member
Administrator
Confirmed, thank you for reporting it!

---------- Post added at 12:07 PM ---------- Previous post was at 12:06 PM ----------

Temporary workaround: add rbsdigital.com to SSL exclusions in Adguard's network settings.
 

Pentlands

Beta Tester
Confirmed, thank you for reporting it!

---------- Post added at 12:07 PM ---------- Previous post was at 12:06 PM ----------

Temporary workaround: add rbsdigital.com to SSL exclusions in Adguard's network settings.
Thanks avatar, i just noticed your edit and was about to apply the exclusion but looked for an update first... i just updated to 5.10.1190.6188 (i missed the 1189 update) and can confirm the RBS issue is resolved without requiring to manually add an exclusion.

Fyi, I'm massively impressed with Adguard and the work you guys are putting into it.

Regrads.
 

avatar

Administrator
Staff member
Administrator
Build 5.10.2029.6341, the same issue has resurfaced.
Again with rbsdigital.com? Strange, it should be in SSL exclusions..
Could you please check the list of SSL exclusions in your network settings?
 

Pentlands

Beta Tester
Rbsdigital.com is NOT listed, the only RBS exclusion is rbsinternational.com

I don't use the rbsinternational.com website as that is for offshore accounts held in Jersey, Guernsey or the Isle of Man. I'd be so lucky to have the money for an offshore account ;)
 

avatar

Administrator
Staff member
Administrator
That's strange, should be in the list.

There's a bug with "Restore defaults" button in network settings in AG, it restores SSL exclusions to the wrong state.
Maybe that's it?
 

Pentlands

Beta Tester
avatar,

I've resolved the issue by re-installing Adguard, choosing not to save any of the settings.

The SSL exclusions list is now much longer than it was and includes rbsdigital.

I still don't think i ever used the 'restore defaults' option, but clearly the SSL exclusions list was corrupt.

Thanks, and many thanks also to Boo Berry for the "Beta tester links and resources" thread, the 'Windows Beta installer download link' was seemless and likely saved me a load of time working out where or how to get the latest Beta build :)
 

Boo Berry

Moderator + Beta Tester
Moderator
Thanks, and many thanks also to Boo Berry for the "Beta tester links and resources" thread, the 'Windows Beta installer download link' was seemless and likely saved me a load of time working out where or how to get the latest Beta build :)
I thought it might come in handy. :D
 
Top