[Windows 7 Beta 5.10.1190.6188] Не закрывается всплывающее окно.

Discussion in 'Контроль качества бета-версий' started by ArgoS, Feb 8, 2015.

  1. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    В панеле задач отображается значок Adguard. Если навести на значок курсор мыши - отображается всплывающее окно с номером версии Adguard и статусом блокировки. Но в последней бете иногда всплывающее окно отображается совершенно в другом месте. На скриншоте видно.
    Безымянный.png
    Появляется иногда после нажатия правой кнопки мыши по значку Adguard в панеле задач. Помогает только полное закрытие программы.
     
  2. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    В бете 5.10.1195.6216 тоже самое. Но это происходит только при первом нажатии после запуска программы.
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    А можно узнать больше о конфигурации вашего монитора?

    Разрешение, размер символов, один или два монитора используется?

    ---------- Post added at 01:52 ---------- Previous post was at 01:51 ----------

    Мы этот баг давно пытаемся отловить, но пока что не особо получается.
    Так что мы его отложили до шестой версии, но все равно ж придется исправлять.
     
  4. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Ноутбук, так что экран один. Разрешение 1600х900. Баг проявляется если открыть меню правой кнопкой мыши быстрее, чем появится всплывающее окно
     
  5. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    А можете на скриншоте показать, где у вас закреплена иконка Adguard?
     
  6. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Вот здесь.
    Безымянный.png
     
  7. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Скажите пожалуйста, а на последней бета-версии повторяется этот дефект?

    Есть надежда, что мы его исправили в 5.10.1198
     
  8. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Нет, проблема осталась.
     
  9. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    В общем, для решения этой проблемы нам нужно проанализировать почему появляется этот значок.

    Я собрал версию с расширенным логгированием:
    https://www.dropbox.com/s/djhd60z8i47kzvq/setup.msi?dl=0

    Чтобы установить ее:
    1. Надо удалить текущую версию
    2. Запустить cmd.exe от имени администратора
    3. Выполнить установку командой msiexec /i setup.msi

    Что нужно делать дальше:
    1. Каким нибудь образом повторить проблему
    2. Как только получилось ее повторить, заархивировать логи: %programdata%\Adguard\Logs и передать мне.

    Помимо логов мне нужно знать:
    1. Когда примерно по времени это произошло?
    2. Что вы делали своими словами.
     
  10. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Установил. Как только будут результаты - напишу.
     
  11. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Лучше наверное на последнюю бету обновиться, у меня на нее большие надежды.
     
  12. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    В 10:07 включил ноутбук. Зашел в браузер. Как только загрузилась домашняя страница - перевёл курсор мышки на значок Adguard. Два раза нажал правой кнопкой мыши по значку Adguard до появления всплывающего окна. Через секунд 5-6 в сплывающее окно появилось на том же месте, как и на первом скриншоте в теме.
    Вот логи.
    http://multi-up.com/1035768
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Мда, логи не очень о многом говорящие:(

    Скажите, а оно хотя бы исчезает после повторного клика на иконке?
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Выложил обновленную версию: 5.10.2002.6237

    Можете ее попробовать?
     
  15. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Не всегда. Но после 2-3 нажатий становится на своё место.
    Сейчас обновился до новой беты и буду следить.
     
  16. Paul_Markey

    Paul_Markey Beta Tester

    Joined:
    Aug 15, 2014
    Messages:
    492
    Такая же проблема была. В последней бета вроде наладилось, пока проблем не замечаю. Единственное что, дак это трей меню зачастую ну уж больно долго прогружается.
     
  17. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,902
    Имеете в виду меню Адгарда в трее, или сам трей?
     
  18. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    После загрузки системы при нажатии правой кнопкой мыши по иконке в трее меню открывается с приличной задержкой. Потом всё без задержки.
     
  19. Paul_Markey

    Paul_Markey Beta Tester

    Joined:
    Aug 15, 2014
    Messages:
    492
    Именно. У меня задержка в среднем составляет секунд 10. Соответственно если сдвинул мышку, менюшка вылазит там где мышь. Да и сама программа тоже довольно долго в первый раз открывается.
     
  20. ArgoS

    ArgoS Beta Tester

    Joined:
    Aug 27, 2014
    Messages:
    93
    Сравнить можно с первым запуском Firefox.