wp.pl

Blaz

Moderator & Translator
Staff member
Moderator
To hide their reklam boxes (class names switch between those two):
Code:
teleshow.wp.pl##._g2xpqw
teleshow.wp.pl##._2pw5mt
For Safari filter as it doesn't support javascript rules correctly:
Code:
@@||rek.www.wp.pl/gaf.js$important,domain=teleshow.wp.pl
@@||static.criteo.net/js/ld/publishertag.js$domain=teleshow.wp.pl
@@||ads.businessclick.com/awrapper$domain=teleshow.wp.pl
@@||googletagservices.com/tag/js/gpt.js$domain=teleshow.wp.pl
@@||pagead2.googlesyndication.com/pagead/js/adsbygoogle.js$domain=teleshow.wp.pl
@@||adv.wp.pl$domain=teleshow.wp.pl
@@||rek.www.wp.pl$domain=teleshow.wp.pl
@@||owabgxis.wp.pl$domain=teleshow.wp.pl
@@||fntajkb.wp.pl$domain=teleshow.wp.pl
@@||e18sohhclse.wp.pl/*/publishertag.js$domain=teleshow.wp.pl
For normal options I guess @seanl can build a nice javascript rule (above rules also work for normal hiding elements, but I think we shouldn't unblock too many urls).
 

Adam

Filters Developer
Staff member
Moderator
Yes it works, but I also hope that would be possible by javascript rule.
Thank you for your help.
 

seanl

Well-Known Member
Removed from English filter:
Code:
abczdrowie.pl,autokrata.pl,autokult.pl,biztok.pl,gadzetomania.pl,hotmoney.pl,kafeteria.pl,kafeteria.tv,komediowo.pl,komorkomania.pl,money.pl,pudelek.tv,sfora.pl,snobka.pl,wawalove.pl,wp.pl,wp.tv,wrzuta.pl#%#document.cookie.split(";").forEach(function(a){-1!=a.indexOf("PWA_adbd")&&(document.cookie=a.replace(/^ +/,"").replace(/=.*/,"=;expires=Thu, 01 Jan 1970 00:00:00 GMT;path=/;domain=."+location.hostname.split(".").reverse()[1]+"."+location.hostname.split(".").reverse()[0]))}); (function(){function a(){"object"==typeof arguments[0]&&(arguments[0].detection=!1);b.apply(window,arguments)}function b(){}function d(){"advertisement"!=arguments[0]&&c.apply(window,arguments)}var c=window.addEventListener;Object.defineProperties(window,{SentinelDetector:{get:function(){return function(){this.start=function(){}}},set:function(){}},getScript:{get:function(){return a},set:function(a){b=a}},addEventListener:{get:function(){return d},set:function(a){c=a}}})})();
Added to English filter:
Code:
abczdrowie.pl,autokrata.pl,autokult.pl,biztok.pl,gadzetomania.pl,hotmoney.pl,kafeteria.pl,kafeteria.tv,komediowo.pl,komorkomania.pl,money.pl,pudelek.tv,sfora.pl,snobka.pl,wawalove.pl,wp.pl,wp.tv,wrzuta.pl#%#(function(b){function a(){"advertisement"!=arguments[0]&&b.apply(window,arguments)}Object.defineProperties(window,{hasSentinel:{get:function(){return function(){return!1}},set:function(){}},addEventListener:{get:function(){return a},set:function(a){b=a}}})})(window.addEventListener);
Please, check the result. On my end the above rule removes an adblock detection screen at video players, but it does not prevent the generation of 'PWA_adbd' cookies which indicates what request is being blocked according to @Blaz's post in the previous thread. I will try to find out what can be done to prevent cookies as well.
 

seanl

Well-Known Member
Not reproduced on my end at the moment. I see instead an endless loading spinner that last until the end of the video.
Please check this rule:
Code:
wp.pl#%#Object.defineProperty(window, 'PWA_adbd', {value: 0});
 

Adam

Filters Developer
Staff member
Moderator
With this rule I do not have message about Adblock, but I have 3 spinning dots and I can not pause and rewind video.
 

seanl

Well-Known Member
Added to English filter:
Code:
teleshow.wp.pl#%#Object.defineProperty(window,'hamper',{value:function(a){return a;}});
Please, check the result.
window.hamper is what they use to obfuscate urls on the browser's side. There is a setting to completely disable it, you can attach
Code:
?noHamper=1
to the url. If this setting is enabled, hamper returns the string itself, so I made it always returns like that. With this rule, the video player will load ad metadatas from the usual url
Code:
rek.www.wp.pl/vad.xml
which is then blocked by $empty rule.
 

Adam

Filters Developer
Staff member
Moderator
On main page - http://www.wp.pl/ - I sometimes see ads/ads leftovers.

upload_2017-5-12_14-5-58.png

I noticed that if I have these ads/ads leftovers I see in source code something like - window.testMess = 'www.wp.pl';

If I add this rule:
Code:
www.wp.pl#%#Object.defineProperty(window, 'testMess', { get: function() { return ; } });
I do not have ads.

By the way, I think the easiest way to reproduce these ads is add this rule to user filter...
Code:
www.wp.pl$replace=/window.testMess = '';/window.testMess = 'www.wp.pl';/,important
 

seanl

Well-Known Member
There is an easier way, append a parameter "?testMess=www.wp.pl" at the url.
http://www.wp.pl/?testMess=www.wp.pl
Currently I don't have time to investigate what they do with this variable. I only see ad leftovers, not ads with Adblock polskie reguły, so I guess it was dealt on your side somehow.

Added to English filter:
Code:
www.wp.pl#%#Object.defineProperty(window,'testMess',{value:'no'});
Please, check the result. They can force this regardless of the value of testMess as can be seen by visiting above url. It is a temporary solution.
 

Adam

Filters Developer
Staff member
Moderator
Ok, thank you.

It is difficult to check it, because I do not see these ads now on www.wp.pl without adding "?testMess=www.wp.pl" parameter, and if I understand correctly this solution does not block ads if I use this link - http://www.wp.pl/?testMess=www.wp.pl

Do you mean that you do not have ads on wp.pl with "?testMess=www.wp.pl" parameter or without?

By the way, this rule was added to "Adblock polskie reguły" and it works on my end:
Code:
/^https:\/\/www\.wp\.pl\/[a-zA-Z0-9_\-=]{500,}/$script,domain=www.wp.pl
but I think if it is possible it would be better to block these ads using JS rule, because they can change this again.
 
Top