[-] www.foumovies.com [Windows]

Adam

Filters Developer
Staff member
Moderator
I can not reproduce with Adguard for Windows.
I also checked this with uBO with default settings and can not reproduce that too.
Maybe try to update filters lists and check again, please.
 

Nzyme

Active Member
I can not reproduce with Adguard for Windows.
I also checked this with uBO with default settings and can not reproduce that too.
Maybe try to update filters lists and check again, please.
I updated all the above listed AG filters in uBO and checked again and see a pop-up window. Have you used the AG filters in uBO or just the default filters which are checked? Can you try to add the AG filters to uBO and check?
 

Adam

Filters Developer
Staff member
Moderator
Do you have "uBlock filters" enabled? There is this rule:
Code:
||onclkds.com/apu.php$script,redirect=noopjs
which should "block" these popups.

I checked only with default filters.
 

Nzyme

Active Member
Do you have "uBlock filters" enabled? There is this rule:
Code:
||onclkds.com/apu.php$script,redirect=noopjs
which should "block" these popups.

I checked only with default filters.
I used the custom filter but the pop-up is still seen. Upon checking the uBO filter log, I see one domain which is responsible for the pop-up (see screenshot)

When I encounter a pop-up for a brief period (a second or so), I see this same link in the address bar of the pop-up window. Not sure why you are not able to see the pop-up window. Can you add this domain to the filter list. Thanks!
 

Attachments

Blaz

Moderator & Translator
Staff member
Moderator
Reproduced here, try these rules:
Code:
||62b70ac32d4614b.com
/pe/bag2?r[]=%3A%2F%2F62b70ac32d4614b.com%2F
foumovies.com##body > a[href^="//"][href*=".com/"][href*=".htm"]
@Adam
The click produces a SessionStorage element "__PPU_SESSION_1_1264781_false" and on another click the LocalStorage element "__PPU_BACKCLCK_1264781"
 

Attachments

Nzyme

Active Member
Reproduced here, try these rules:
Code:
||62b70ac32d4614b.com
/pe/bag2?r[]=%3A%2F%2F62b70ac32d4614b.com%2F
foumovies.com##body > a[href^="//"][href*=".com/"][href*=".htm"]
I added your custom filter to uBO (under "My filters") and also added my custom filter "||2778255fe56.com$script,important" but I still see the pop-up window :(

I am seeing a pop-up when clicking on the space highlighted in the screenshot.
 

Attachments

Blaz

Moderator & Translator
Staff member
Moderator
Try open development tools of your browser and expand the body and post screenshot.
 

Nzyme

Active Member
I applied one more filter and since then I don't see the pop-up. I have attached the screenshot of the 3 filters that I have applied. Can you add them to the main English list considering that they are responsible for the ads/pop-up?
 

Attachments

Adam

Filters Developer
Staff member
Moderator
@Nzyme I do not see any request to 2778255fe56.com on my side and I really can not reproduce with uBO with default settings. Could you check in logger if you have something like this, like on my screenshot below?

upload_2017-6-17_16-16-10.png

As I know redirecting this script should "block" these popups, but if it does not work at your end, please check this rule:
Code:
foumovies.com##script:inject(noeval-if.js, charCodeAt)
@Blaz in Adguard for Windows these popups should be blocked by this rule:
Code:
||onclkds.com/apu.php?$replace=/^[\s\S]*\$//,important
if it does not work, please check this:
Code:
foumovies.com#%#(function() { var _eval = window.eval; window.eval = function(a) { if ( a.toString().indexOf('charCodeAt') === -1 ) { _eval(a); return; } }; })();
I am able to reproduce these popups only if I disable rules mentioned above.
 

Nzyme

Active Member
@Nzyme I do not see any request to 2778255fe56.com on my side and I really can not reproduce with uBO with default settings. Could you check in logger if you have something like this, like on my screenshot below?

View attachment 8771

As I know redirecting this script should "block" these popups, but if it does not work at your end, please check this rule:
Code:
foumovies.com##script:inject(noeval-if.js, charCodeAt)
I see that at my end (see attached screenshot) but the rule based on which it is blocked is different.

I removed all the three custom filers that I had added earlier under "My Filters" in uBO and just used your one filter:

Code:
foumovies.com##script:inject(noeval-if.js, charCodeAt)
and now it works. I no longer see any pop-ups :) Thanks for all your efforts guys.
 

Attachments

Blaz

Moderator & Translator
Staff member
Moderator
if it does not work, please check this:
Code:
foumovies.com#%#(function() { var _eval = window.eval; window.eval = function(a) { if ( a.toString().indexOf('charCodeAt') === -1 ) { _eval(a); return; } }; })();
That rule worked, the other one (which was already applied previously) not.
 
Top