Youtube hang when blocking beginning video ads with new website design

Avenger

New Member
I was previously using the "youtube classic" extension to avoid the new terrible youtube design but the old version has now been 100% removed and the new design forced as the only option just a few days ago. Ever since this change youtube videos now hang for several seconds when they start to play and the "skip ad" button is present on the right hand bottom side of the video.

This is highly annoying and basically defeats the entire purpose of using an adblocker to avoid seeing nonsense before an actual video.

What's the problem? I have searched for a solution and found many people experiencing the same issue.. All my utilized filters are up to date and the problem still persists.
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
Enable the experimental filter and clear your browser's cache. The new YouTube ads are known about and there's some test rules in the experimental filter for them.
 

Avenger

New Member
Enable the experimental filter and clear your browser's cache. The new YouTube ads are known about and there's some test rules in the experimental filter for them.
Oddly enough, I enabled the filter and initially experienced no change. I then disabled it and the problem seems to now be fixed?... Will update if youtube reverts back to having issues but this seems to now be strangely resolved.

Thanks.
 

Avenger

New Member
Enable the experimental filter and clear your browser's cache. The new YouTube ads are known about and there's some test rules in the experimental filter for them.
The problem is still occuring at random . The "Experimental filter" appears to have done nothing now.
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
Afraid not, the developers can't reproduce the ads (none of their accounts have gotten the new ads yet).

This issue affects all ad blockers and only certain Google/YouTube accounts. You might try logging out of YouTube or an incognito window for YouTube as a workaround, but other than that there's nothing that can be done currently.

Ongoing topic here: https://forum.adguard.com/index.php?threads/adguard-not-working-on-youtube.38663/
 

Avenger

New Member
Afraid not, the developers can't reproduce the ads (none of their accounts have gotten the new ads yet).

This issue affects all ad blockers and only certain Google/YouTube accounts. You might try logging out of YouTube or an incognito window for YouTube as a workaround, but other than that there's nothing that can be done currently.

Ongoing topic here: https://forum.adguard.com/index.php?threads/adguard-not-working-on-youtube.38663/
I don't have an account. I watch without logging in. Problem still occures 80% of the time.
 

Avenger

New Member
Afraid not, the developers can't reproduce the ads (none of their accounts have gotten the new ads yet).

This issue affects all ad blockers and only certain Google/YouTube accounts. You might try logging out of YouTube or an incognito window for YouTube as a workaround, but other than that there's nothing that can be done currently.

Ongoing topic here: https://forum.adguard.com/index.php?threads/adguard-not-working-on-youtube.38663/
Have you tried playing videos without logging in and using a US IP address?

This seems rather trivial to reproduce. Not sure where the issue is coming from in trying to do so...
 

Boo Berry

Moderator + Beta Tester
Moderator
I can't reproduce it yet, neither can the filter devs as far as I know.

It only happens to certain people and Google accounts. Google hasn't rolled it out for everyone yet.
 

Avenger

New Member
I can't reproduce it yet, neither can the filter devs as far as I know.

It only happens to certain people and Google accounts. Google hasn't rolled it out for everyone yet.
I understand that but like I said, I'm not logged into any google account when this happens so that eliminates that theory.

Have you tried with a US IP address?
 

melissaazevedo

New Member
I would like to suggest YouTube vanced app which helps users to watch YouTube videos ads free if there is not a solution to solve this problem or until the problem get solved
 

Avenger

New Member
Enabling the experimental filter seemed to work up until recently. Now this is happening all over again in Firefox for PC. Doesn't happen in Firefox on Android though...

Any new fixes? I updated the filters, cleared cache, etc. Same problem.
 
Top